Pubic search
Incident Report for ISAN
Resolved
The public search is now functioning
Posted Apr 12, 2023 - 19:48 CEST
Identified
The public ISAN search is out of service. Our team is currently working on a solution.
You can still search the ISAN registry if you are logged in the ISAN system. Might you need credentials, please contact one of the ISAN registration agencies https://web.isan.org/public/en/select_registration_agency.
Posted Apr 12, 2023 - 14:56 CEST
This incident affected: ISAN Web Interface (production).